Problem with Mobile Mapper

Dedicated exclusively to field herping.

Moderator: Scott Waters

Post Reply
s_stocking
Posts: 79
Joined: October 11th, 2012, 6:37 pm
Location: Las Vegas, Nv

Problem with Mobile Mapper

Post by s_stocking »

Greetings all,

I'm looking for help with the Mobile Mapper. I downloaded it and began using it this spring, I now have 85 records, mostly in Clark County, Nevada, but also some records in New Mexico, Arizona, and California. However, every time I try to sync with the HERP website I get "There was an error submitting the record. Invalid API key". Bottom line I have 80+ records I'd like to put into HERP but cannot. Any help would be greatly appreciated-

Steve

Jimi
Posts: 1930
Joined: December 3rd, 2010, 12:06 pm

Re: Problem with Mobile Mapper

Post by Jimi »

Hi Steve,

How's it going? Did you ever get any responses to your tech question?

cheers,
Jimi

User avatar
chris_mcmartin
Posts: 2443
Joined: June 8th, 2010, 11:13 pm
Location: Greater Houston TX Area
Contact:

Re: Problem with Mobile Mapper

Post by chris_mcmartin »

Did you designate NAHERP as the database of choice to sync records?

http://www.naherp.com/app.php

You should have an API Key generated by the website, which you will need to put into MobileMapper.

s_stocking
Posts: 79
Joined: October 11th, 2012, 6:37 pm
Location: Las Vegas, Nv

Re: Problem with Mobile Mapper

Post by s_stocking »

Thanks for the replies Jimi and Chris. No I haven't received a response to my tech request yet, but I think I've found the problem; my iPhone I synching right now. User error on my part :)

Jimi I'm headed to the pickle party with Jason and Bob, see you tomorrow-

Jimi
Posts: 1930
Joined: December 3rd, 2010, 12:06 pm

Re: Problem with Mobile Mapper

Post by Jimi »

Alright, see you tomorrow AM Steve. It'll be fun. Sorry about the weather - prepare to freeze ass.

cheers,
Jimi

User avatar
Biker Dave
Posts: 2863
Joined: June 10th, 2010, 6:56 pm
Location: Wittmann,AZ

Re: Problem with Mobile Mapper

Post by Biker Dave »

Im having the same problem. I was able to sync all my NAHERP records awbile back but now the API is no longer valid? How do I fix this?

s_stocking
Posts: 79
Joined: October 11th, 2012, 6:37 pm
Location: Las Vegas, Nv

Re: Problem with Mobile Mapper

Post by s_stocking »

Biker Dave, I had to contact Don Becker- I'm not sure what magic he worked, but he was able to fix it; below is his explanation of what happened in my case:

"So, what looks like happened, is that you had the app configured for Herp Mapper when you took the records, but then changed it to the NAHERP configuration before you submitted. That would explain the initial error you got about your API key. It was trying to use your NAHERP API key with HerpMapper.

So... all your records are there, but the species IDs are wrong, and they don't have any country/state/county data. The vouchers, time/date, GPS are all saved. I fixed the page so that your records are listed when you click "View My Records", but all you will see is the camera icon showing that it has a voucher. Click the camera to view it, and you should be able to edit it to correct the data.

If they were all in the same country, state, or county, I can bulk update them for that at least."

I hope this helps-

User avatar
Biker Dave
Posts: 2863
Joined: June 10th, 2010, 6:56 pm
Location: Wittmann,AZ

Re: Problem with Mobile Mapper

Post by Biker Dave »

Thanks! I'll contact Don ...

Post Reply